Home > MPLS Lab Sim > MPLS VPN Lab Sim

MPLS VPN Lab Sim

The Indigo IT Company is a banking service that is using EIGRP AS 1 as the IGP in its network.Indigo IT Company has decided to establish connectivity between two of its sites. AdvanceNet, a service provider, has been selected by the Indigo IT Company to provide the connectivity between the two sites.

For this implementation, AdvanceNet is using a MPLS VPN solution. AdvanceNet has already established MPLS connectivity between all of their PE routers. MPBGP connectivity has also been established on all PE routers.

Indigo IT Company has successful completed all necessary tasks on the CE routers, and AdvanceNet has successfully completed all necessary MPLS VPN configuration tasks on PE12.

MPLS_VPN_topology.jpgYour task is to successfully complete the implementation of the VPN connection by configuring the MPLS VPN on PE11 using the following information:
Privileged mode password: *********
EIGRP is to be used the PE-CE protocol for the VPN.
MPBGP is being used to propagate VPN routing information between the PE routers.
The interface supporting the Indigo Company is Serial0/0 and will have an IP address
of 150.1.244.18 255.255.255.240.

The following has been assigned to Indigo’s VPN:
The VRF name is Customer_6
The RD is 6:10
The route target for import is 14:10.
The route target for export is 14:10.
Configure EIGRP between CE11A and PE11 using AS number 10.
Redistribute from BGP to EIGRP AS 10 using metric string of 10000 100 255 11500.
Redistribute from EIGRP AS 10 to BGP using a metric of 1.
VPN is operational when you can see routes for both the local (10.1.11.10) and the remote (10.1.12.0) sites in the VRF routing table

Answer and Explanation

On PE11 configure these commands

ip vrf Customer_6
rd 6:10
route-target both 14:10
!
interface s0/0
ip vrf forwarding Customer_6
ip address 150.1.244.18 255.255.255.240
!
router eigrp 10
address-family ipv4 vrf Customer_6
autonomous-system 10
network 150.1.244.16 0.0.0.15
redistribute bgp 65001 metric 10000 100 255 1 1500
!
router bgp 65001
address-family ipv4 vrf Customer_6
redistribute eigrp 10 metric 1

 

show ip bgp vpnv4 all

If we can see routes to the prefix 10.1.11.0 and 10.1.12.0 then your configuration is correct!

Notice: There is another Lab Sim in the MPLS 642-691 Exam, it is the MPLS TDP Neighbor Lab Sim

Categories: MPLS Lab Sim Tags:
  1. Osama
    June 9th, 2011 at 08:28 | #1

    I had the exam and found that there is something missing in your LAB…

    1- under the Eigrp we have to add network 10.0.0.0
    2- the lab provide us with the subinterface Serial0/0.101 with DLCI 101, so we have to configure the main interface with the frame-relay encapsulation and don’t forget the DLCI 101 under the sub interface.

  2. jaesonv
    October 9th, 2011 at 13:29 | #2

    I haven’t taken the exam BUT IF the 10-series IP is for the core addressing, it doesn’t need to be part of the advertised networks in EIGRP.

    The labs above are very much the labs in the MPLS course. I’ve got that in Dynamips as well. 🙂

  3. Sherif
    October 15th, 2011 at 21:38 | #3

    I agree there is no need for network 10.0.0.0 command, these routes should be advertised by the customer routers and sh ip route vrf Customer_6 should prove this, besides there is no info about the PE having an interface facing the customer in 10.0.0.0 network

  4. SC
    October 21st, 2011 at 19:06 | #4

    hi all
    please notice that the requirements is to build a “Customer_6” and to use “The RD is 6:10”.
    there is a mismatch in the RD in the answer section
    “ip vrf Customer_6
    rd 16:10->>>>>>should be rd 6:10

  5. Gonzalo
    March 8th, 2012 at 19:26 | #5

    Hello.
    There a slite mistake. I did the exam yesterday and it was exactly like this one but:
    router eigrp 1 (should be 10 here)
    address-family ipv4 vrf Customer_6
    autonomous-system 10
    network 150.1.244.16 0.0.0.15
    redistribute bgp 65001 metric 10000 100 255 1 1500
    !
    router bgp 65001
    address-family ipv4 vrf Customer_6
    redistribute eigrp 10 metric 1

  6. iptut
    April 11th, 2012 at 11:44 | #6

    @SC, Gonzalo: Yes, thanks for your detection. I updated them!

  7. palani
    April 15th, 2012 at 05:48 | #7

    router eigrp 10
    address-family ipv4 vrf Customer_6
    autonomous-system 10

    can anyone please explain why router eigrp 10
    i strongly believe it should be 1

  8. palani
    April 15th, 2012 at 05:57 | #8

    where 1 is the AS no of provider and 10 is the AS number of the customer

  9. lainaserge
    June 16th, 2012 at 20:10 | #9

    guys below the right config:

    ip vrf Customer_6
    rd 6:10
    route-target both 14:10
    !
    interface s0/0
    ip vrf forwarding Customer_6
    ip address 150.1.244.18 255.255.255.240

    router bgp 65001
    address-family ipv4 vrf Customer_6
    redistribute eigrp 10 metric 1
    !
    router eigrp 1
    address-family ipv4 vrf Customer_6
    autonomous-system 10
    network 150.1.244.16 0.0.0.15
    redistribute bgp 65001 metric 10000 100 255 1 1500

  10. Nisha
    July 19th, 2012 at 07:22 | #10

    Can any one provide GNS file for this lab … plsss.. my id is abc970258@gmail.com