Home > Practice CCIP GNS3 Lab > Simple MPLS GNS3 Lab

Simple MPLS GNS3 Lab

In this article we will do a very basic lab to understand the fundamental concept of MPLS.

IOS: c3660-jk9o3s-mz.124-17.bin

Topology:

Basic_MPLS_GNS3_Topology.jpg

First configure EIGRP AS 100 on R1, R2 and R3

R1:

R1#configure terminal
R1(config)#interface f0/1
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.12.0 0.0.0.255

R2:

R2#configure terminal
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface f0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 192.168.12.0 0.0.0.255
R2(config-router)#network 192.168.23.0 0.0.0.255

R3:

R3#configure terminal
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 192.168.23.0 0.0.0.255

Now check these 3 routers with the show ip route command, we can see all the routers learned all the routes in EIGRP AS 100.

R1 Initial Configuration

Initial_R1.jpg

R2 Initial Configuration

Initial_R2.jpg

R3 Initial Configuration

Initial_R3.jpg

We can also check the EIGRP neighbor status with the show ip eigrp neighbors command. For example on R1 we have

Initial_R1_show_ip_eigrp_neighbors.jpg

Of course if everything is correct we can ping from R1 to R3

Initial_R1_ping_R3.jpg

To run MPLS, each router must turn on cef with the “ip cef” command

On R1, R2, R3

R1/R2/R3(config)#ip cef

Now we need to enable MPLS on each interface

R1:
R1(config)#interface f0/1
R1(config-if)#mpls ip

R2:
R2(config)#interface f0/0
R2(config-if)#mpls ip
R2(config)#interface f0/1
R2(config-if)#mpls ip

R3:
R3(config)#interface f0/0
R3(config-if)#mpls ip

A message appears when we enable MPLS (default LDP will be used). For example, after enabling “ip cef” and “mpls ip” on R1:

R1_Enable_MPLS.jpg

Now use the show mpls interfaces we can see which interfaces are running MPLS

R1

R1_show_mpls_interfaces.jpg

R2

R2_show_mpls_interfaces.jpg

R3

R3_show_mpls_interfaces.jpg

Check the neighbor’s relationship of these routers with the show mpls ldp neighbor command

R1

R1_show_mpls_ldp_neighbor.jpg

R2

R2_show_mpls_ldp_neighbor.jpg

R3

R3_show_mpls_ldp_neighbor.jpg

TDP has been the default label distribution protocol. Starting in Cisco IOS Release 12.4(3), the default MPLS label distribution protocol is LDP. If you want to run Tag Distribution Protocol (TDP), you can enable TDP on all interfaces by the command “mpls label protocol tdp in global configuration mode

R(config)#mpls label protocol tdp

Or enable TDP on a specific interface

R(config-if)#mpls label protocol tdp

Note: The TDP/LDP configuration in interface mode overwrites the configuration in global configuration mode.

Categories: Practice CCIP GNS3 Lab Tags:
  1. Leomar
    August 30th, 2012 at 05:17 | #1

    I did always enjoy the labs, ahoutlgh I will admit some of the recent walkthroughs have had info a bit beyond me (for now), once I catch up and get to the CCIE myself, I’ll be referring back here a lot for that.Still, I like your idea for what to do now, if nothing else it’ll be very useful.

  2. mpls
    November 17th, 2012 at 06:44 | #2

    why does use tdp

  3. tariq
    April 13th, 2013 at 16:58 | #3

    thanks it was so easy to understand

  4. logan
    June 6th, 2013 at 15:19 | #4

    made world so simple…………….thanks mate

  5. Anonymous
    February 11th, 2014 at 19:59 | #5

    download latest dumps from
    9
    t
    u
    t
    .
    w
    e
    b
    s
    .
    c
    o
    m

  6. yassine
    April 28th, 2014 at 10:52 | #6

    thank youu ! simple and usefull

  7. March 27th, 2017 at 01:26 | #7

    If you desire to get much from this piece of writing then you have to apply these techniques to your won web site.

  1. No trackbacks yet.