Home > Practice CCIP GNS3 Lab > Basic MPLS VPN VRF GNS3 Lab

Basic MPLS VPN VRF GNS3 Lab

Virtual Routing and Forwarding Table (VRF) allows to create multiple routing tables within a single router. Each of them is assigned to a customer; therefore customers can use the same IP (even private IP) with other customers without confusing the PE router.

GNS3_MPLS_VPN_VRF_topology.jpg

In the above example, R0 is the Provider Edge (PE) router which is on the ISP side while R1 and R2 are customer routers (CustomerA and CustomerB respectively).

R0(config)#ip vrf CustomerA
R0(config-vrf)#rd 1:1
R0(config-vrf)#ip vrf CustomerB
R0(config-vrf)#rd 2:2

The first command “ip vrf CustomerA” enters VRF configuration mode and defines the VPN routing instance by assigning a VRF name (CustomerA).
The second command “rd 1:1” creates routing and forwarding tables. The “rd” command is in the format ASN:nn or IP-address:nn

R0(config)#interface f0/0
R0(config-if)#ip vrf forwarding CustomerA
R0(config-if)#ip address 10.0.0.1 255.255.255.252
R0(config-if)#no shutdown

R0(config)#interface f0/1
R0(config-if)#ip vrf forwarding CustomerB
R0(config-if)#ip address 10.0.0.1 255.255.255.252
R0(config-if)#no shutdown

The “ip vrf forwarding CustomerA” associates the routing and forwarding table “CustomerA” with interface f0/0.

At customer sites we don’t need to do any special configuration, just assign an IP address of each interface and “no shut” them.

R1(config)#interface f0/0
R1(config-if)#ip address 10.0.0.2 255.255.255.252
R1(config-if)#no shutdown

R2(config)#interface f0/0
R2(config-if)#ip address 10.0.0.2 255.255.255.252
R2(config-if)#no shutdown

R0 router recognizes each customer IP by the “Customer name” (CustomerA or CustomerB)

GNS3_MPLS_VPN_VRF_R0_ping_vrf.jpg

Notice that the pings are still successful when two customers use the same IP address.

R1 and R2 can ping to PE router with the same IP

GNS3_MPLS_VPN_VRF_R1_ping.jpg

GNS3_MPLS_VPN_VRF_R2_ping.jpg

We can also see what is inside R0’s VRF table with the “show ip vrf” command

GNS3_MPLS_VPN_VRF_R0_show_ip_vrf.jpg

Categories: Practice CCIP GNS3 Lab Tags:
  1. 2bccie
    August 11th, 2011 at 11:48 | #1

    why the ip address of f0/0 and f0/1 is the same ?

  2. iptut
    August 21st, 2011 at 01:54 | #2

    @2bccie: Yes, it is the beauty of MPLS VPN, we can use the same IP address space on different interfaces of the ISP router (in this case R0). This is good for our customers because they might use the same IP range with each other and they don’t need to change their IP address ranges.

  3. TRIGUN
    February 17th, 2012 at 10:19 | #3

    Hi iptut. what is the meaning of “nn” in ASN:nn ? and the ASN? autonomous system number? thanks

  4. Hector
    April 9th, 2012 at 14:59 | #4

    I think you should have added the command output of both :

    sh ip route vrf CustomerA
    sh ip route vrf CustomerB

    This shows the other reason why MPLS VPN is great at creating multiple separate route tables.

  5. Tahir
    July 18th, 2012 at 22:51 | #5

    Both customers are using same IP addresses the networks seem physically same but are Virtually Private. That is the beauty of VPN.

  6. Leo
    August 29th, 2012 at 18:44 | #6

    AVPN is the same as EVPN there’s just a difference in CPE oweinshrp. In EVPN all hardware including CPE is owned by the telco (in this case AT&T). For AVPN the CPE is provided by the customer and is not managed. There are also some minor CDR pricing changes.

  7. HASSAN
    January 10th, 2013 at 17:28 | #7

    i still don’t understand that why we use same Ips??? on Router 0

  8. anil Rana
    February 8th, 2013 at 06:51 | #8

    the same ip address or net mask doesn’t gets any problem

    configuration is correct

  9. Anonymous
    February 11th, 2014 at 19:59 | #9

    download latest dumps from
    9
    t
    u
    t
    .
    w
    e
    b
    s
    .
    c
    o
    m

  10. Raja
    May 5th, 2016 at 11:49 | #10

    Hello iptut,

    One query: Can we Telnet or SSH the vrf ? if so how can we configure them.

    Cheers,

    Raja

  11. Parker
    May 19th, 2016 at 15:28 | #11

    These two commands might be helpful as well.

    R1#ping vrf CustomerA ip 10.0.0.2

    R1#ping vrf CustomerB ip 10.0.0.2

  12. September 22nd, 2017 at 14:27 | #12

    Just Passed 300-320 exam with the help of Expert’s made exam dumps from Braindumpskey. I just want experience of mine here. Visit the link guys for Details of More Certifications: https://www.braindumpskey.com/exam/300-360.html