Archive

Archive for the ‘Practice CCIP GNS3 Lab’ Category

Basic MPLS VPN VRF GNS3 Lab

May 9th, 2011 12 comments

Virtual Routing and Forwarding Table (VRF) allows to create multiple routing tables within a single router. Each of them is assigned to a customer; therefore customers can use the same IP (even private IP) with other customers without confusing the PE router.

GNS3_MPLS_VPN_VRF_topology.jpg

In the above example, R0 is the Provider Edge (PE) router which is on the ISP side while R1 and R2 are customer routers (CustomerA and CustomerB respectively).

Read more…

Categories: Practice CCIP GNS3 Lab Tags:

Simple MPLS GNS3 Lab

April 4th, 2011 7 comments

In this article we will do a very basic lab to understand the fundamental concept of MPLS.

IOS: c3660-jk9o3s-mz.124-17.bin

Topology:

Basic_MPLS_GNS3_Topology.jpg

First configure EIGRP AS 100 on R1, R2 and R3

R1:

R1#configure terminal
R1(config)#interface f0/1
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.12.0 0.0.0.255

R2:

R2#configure terminal
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface f0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 192.168.12.0 0.0.0.255
R2(config-router)#network 192.168.23.0 0.0.0.255

R3:

R3#configure terminal
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 192.168.23.0 0.0.0.255

Now check these 3 routers with the show ip route command, we can see all the routers learned all the routes in EIGRP AS 100.

Read more…

Categories: Practice CCIP GNS3 Lab Tags: