Home > BGP + MPLS 642-691 Exam > BGP Fundamentals 3

BGP Fundamentals 3

Here you will find answers to BGP Fundamentals – Part 3

Question 1

Refer to the configuration shown. What could cause the BGP prefixes from the 10.1.1.1 BGP peer to be absent from the routing table?
!
interface loopback0
ip address 10.10.10.10 255.255.255.255
!
router bgp 51001
synchronization
bgp log-neighbor-changes
bgp confederation identifier 51000
bgp confederation peers 51002 51003
network 10.0.0.0
neighbor 192.168.1.14 remote-as 51021
neighbor 192.168.1.18 remote-as 51022
neighbor 10.1.1.1 remote-as 51001
neighbor 10.1.1.1 next-hop-self
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.2.2.1 remote-as 51002
neighbor 10.2.2.1 ebgp-multihop 255
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.3.3.1 remote-as 51003
neighbor 10.3.3.1 ebgp-multihop 255
neighbor 10.3.3.1 update-source Loopback0
auto-summary
!
router rip
network 10.0.0.0
!

A. intraconfederation EBGP configurations error
B. autosummarization
C. ebgp-multihop issue
D. BGP synchronization
E. EBGP configurations error

 

Answer: D

Question 2

The core routers within a transit AS are running both IBGP and IGP. The edge routers within the transit AS are using the next-hop-self option to establish the IBGP sessions. What can be implemented to improve the routing performance to all external prefixes?

A. enable route redistribution from BGP into IGP
B. disable BGP synchronization on all the core routers
C. enable CEF on all the core and edge routers
D. enable route redistribution from IGP into BGP
E. use route reflectors within the core

 

Answer: C

Question 3

What does the BGP synchronization rule prevent?

A. sub-optimal routing within a transit AS
B. routing black holes within a transit AS
C. routing loops within a transit AS
D. recursive routing lookups
E. scalability issues of redistributing BGP into an IGP

 

Answer: B

Question 4

Which one of these statements regarding intraconfederation EBGP sessions is correct?

A. Intraconfederation EBGP neighbors must be directly connected.
B. An intraconfederation EBGP session behaves like an IBGP session when propagating routing updates. 
C. Member-AS numbers are removed when a router sends a BGP update over an intraconfederation EBGP session. 
D. Updates from an intraconfederation EBGP neighbor are subject to the BGP split horizon rule. 
E. Intraconfederation EBGP sessions must be established over loopback interfaces.

 

Answer: B

Question 5

What state will a BGP session move to immediately after the router sends a BGP Open message to its neighbor?

A. active
B. OpenConfirm
C. OpenSent
D. established
E. idle

 

Answer: C

Question 6

In the diagram, the customer is using BGP to connect to a single ISP ober two permanent links. In this scenario, which input and output prefix-list filtering is typically enabled on the ISP routers? (Choose two)

connect_ISP_multiple_links.jpgA.    ip prefix-list test-in permit 10.1.1.0/24 le 32
B.    ip prefix-list test-in permit 10.0.0.0/8 le 32
C.    ip prefix-list test-in permit 0.0.0.0/0
D.    ip prefix-list test-out permit 10.1.1.0/24 le 32
E.    ip prefix-list test-out permit 10.0.0.0/8 le 32
F.    ip prefix-list test-out permit 0.0.0.0/0

 

Answer: A F

Question 7

Refer to the BGP configurations and the show outputs in the diagram. What are two reasons why the 197.1.0.0/16 and 192.168.1.0/30 prefixes are not in the BGP table of WGR1? (Choose two)

router bgp 1
no synchronization
bgp log-neighbor-changes
network 192.168.1.0
network 197.1.0.0 mask 255.255.0.0
neighbor 192.168.1.14 remote-as 22
auto-summary

BGP_show_ip_route.jpg

BGP_show_ip_bgp.jpg

A. auto-summary is enabled.
B. The 197.1.0.0/16 prefix is not in the routing table of WGR1.
C. The 192.168.1.0/30 prefix is not in the routing table of WGR1.
D. The network 192.168.1.0 command defaults to the classful mask.
E. The aggregate-address 197.1.0.0 255.255.0.0 summary-only command should be used instead of the network 197.1.0.0 mask 255.255.0.0 command.

 

Answer: B D

Categories: BGP + MPLS 642-691 Exam Tags:
  1. CW
    May 25th, 2011 at 16:19 | #1

    @ IPTUTE; can u please explain the answers for Q7 are B & D?

    BTW big thanks for the great support, pl do have explanations for each and every questions.

  2. Jack
    June 7th, 2011 at 03:56 | #2

    For Q7, in order to advertise a network to external, the exact match must be met in ip routing table. For this case, its want to advertise 197.1.0.0/16 to external, but the problem is, there is no exact match in the ip routing table. Thus, it won’t place in BGP table. On the others hand, since 192.168.1.0 is configured classful boundary under BGP (without specify the mask), so its will just advertise and place 192.168.1.0/24 under BGP table.

  3. Kadeesa
    July 17th, 2011 at 06:34 | #3

    What is the difference between Black holes and loops ?

  4. maximus
    September 25th, 2011 at 02:33 | #4

    @ Kadeesa,

    A black hole is when traffic goes and disappears mysteriously…

    A loop is when traffic goes too and from a destination until the TTL (time to live) expires…

    Hope this helps,
    Maximus

  5. Tamirat
    November 1st, 2011 at 12:47 | #5

    I am not clear for question #7
    Please someone help on this

  6. matrix
    March 11th, 2012 at 07:01 | #6

    @Jack,
    can u tell me,why there is no exact match for 197.1.0.0/16,even though we have advertised 197.1.0.0/16 correctly under BGP routing process with–network 197.1.0.0 mask 255.255.0.0 — command i.e. with /16 mask?

    I think this is happening because “auto summary” is enabled under bgp process.

    So answer should be A & D…

    Plz correct me if Im wrong…

  7. spider
    March 21st, 2012 at 20:40 | #7

    @matrix

    Network command is not enough to advertise subnet to must have exact route in IGP routing table

  8. RA
    July 25th, 2012 at 22:09 | #8

    @spider
    Valuable note *Network command is not enough to advertise subnet to must have exact route in IGP routing table*

  9. Dinesh Kumar
    December 7th, 2012 at 02:14 | #9

    in CCNA there is tutorial available for each topic before taking the questions and answers. but here it was not available if its available better for us to recalling… Since CCNA explanation given was very simple to learn by anyone.. same expecting for each topic in CCNP as well as CCI………..

  1. No trackbacks yet.